JS-让IE6、IE7、IE8支持html5

插件介绍
用于解决IE9以下版本浏览器对HTML5新增标签不识别,并导致CSS不起作用的问题。所以我们在使用过程中,想要让低版本的浏览器,即IE9以下的浏览器支持,那么这款html5shiv.js是一个非常好的选择!

JS下载

js下载 http://www.ijquery.cn/js/html5shiv.js
官方网站 https://code.google.com/p/html5shiv/
官方下载 https://github.com/aFarkas/html5shiv/releases

使用教程

<!-- [if lt IE 9] -->
<script type="text/javascript" src="/js/html5shiv.js"></script>
<!--[endif]-->

上面这段代码仅会在IE浏览器下运行,还有一点需要注意,在页面中调用Html5.js文件必须添加在页面的head元素内,因为IE浏览器必须在元素解析前知道这个元素,所以这个js文件不能在页面底部调用。